シンクグラフィカ札幌

サポート掲示板跡地(2)

こちらの掲示板は終了しました。ご質問などはサポートセンターをご利用ください。

Re:Re:Re:Re:Re:Re:Re:また動きません(3834日経過)
2009-03-22 01:22:41 / 和田な、なんだったんでしょうね・・・。でもたまにあるみたいで、先日もmimeエンコードだけできないサーバというのがありました・・・。それはおそらくJcodeがインストールされてるんだけど、バージョンが古いとか、BASE64が入っていないサーバだったのだと思います。古いサーバも考え物ですねぇ…。
Re:Re:Re:Re:Re:Re:また動きません(3835日経過)
2009-03-21 13:35:00 / りー事後報告です
S-JIS版に切り替えても動かず、別のサイトの物も動かず
わけわからんと思い、納期も近かったのでサーバーを別の会社に変えたら
何の問題もなく、動きました
サーバーは ヘテルムサーバーです

前のサーバーに設置されていたsendmailが設定されていなかったのかもしれないです。
Re:Re:Re:Re:Re:また動きません(3838日経過)
2009-03-18 01:51:45 / 和田ほんとごめんなさいね・・・。なんだろうなぁ・・・。ツメが甘くてほんとごめんなさい・・・。
Re:Re:Re:Re:また動きません(3838日経過)
2009-03-18 01:17:35 / リーありがとうございます。
通常の物(check.cgiで指定している物)を2回と和田さんが掲載された物を入れましたが無理でした
このエラーで検索していると、Verが古いものじゃないと駄目だとか書いてある記事がありましたが
お手上げですw

何が悪いのかさっぱりなのですが めげずにS-JIS版を試してみたいと思います

正直自分も和田さんと同じように家でWEBの仕事をしている人間ですが
設置に関する事は完全に自力で今までやってきました
初めてこの手の質問しましたw
プログラムには弱いのと、マニュアルやHPのところどころに笑いの精神を入れる和田さんを尊敬してますw

あの、監視動画もたまに見てます
これからもがんばってください
Re:Re:Re:また動きません(3838日経過)
2009-03-18 01:05:10 / 和田添付のJcode.zipを解凍して、中に入っているJcodeフォルダとJcode.pmをsend.cgiと同じ階層にアップしてみてください。もしそれでもうまく動かないようであれば、サポートではお手上げだと思います。Jcode.zip
Re:Re:また動きません(3838日経過)
2009-03-18 00:22:32 / りー和田さんこんばんわ
私も遠藤さんと同じ状態になっています
チェックCGIでセンドメールは
/usr/lib/sendmailと言われているのですが
/usr/bin/sendmail なのです。
両方変えて見ても結果は同じで
send.cgiのPerlの宣言の下に
use CGI::Carp qw(fatalsToBrowser);
を入れました所
Software error:
Can't locate loadable object for module Jcode::Unicode in @INC (@INC contains: /usr/lib/perl5/i386-linux /usr/lib/perl5 /usr/lib/perl5/site_perl/i386-linux /usr/lib/perl5/site_perl /usr/lib/perl5/site_perl .) at (eval 3) line 1

Software error:
[Wed Mar 18 00:16:22 2009] send.cgi: Can't locate loadable object for module Jcode::Unicode in @INC (@INC contains: /usr/lib/perl5/i386-linux /usr/lib/perl5 /usr/lib/perl5/site_perl/i386-linux /usr/lib/perl5/site_perl /usr/lib/perl5/site_perl .) at (eval 3) line 1 Compilation failed in require at /usr/lib/perl5/Carp.pm line 119.

Software error:
Can't locate auto/Jcode/Unicode/utf8_euc.al in @INC (@INC contains: /usr/lib/perl5/i386-linux /usr/lib/perl5 /usr/lib/perl5/site_perl/i386-linux /usr/lib/perl5/site_perl /usr/lib/perl5/site_perl .) at Jcode/Unicode.pm line 64

この3連発で困っています。
動作的には 遠藤さんと同じで デバッグもスパムブロックも全部動いてました

何が悪いのか教えてください
Re:また動きません(3846日経過)
2009-03-10 10:40:59 / 和田SPAM BLOCKが表示されてるっつーことは動作はしていると思うので、
あとは文字コードの関係ですかねぇ・・・。HTMLからCGIにPOSTした際に発生する処理中のエラーということで、あとは神のみぞ知る領域ですね・・・。

send.cgiのPerlの宣言の下に
use CGI::Carp qw(fatalsToBrowser);
というのを入れるとエラーの内容を知ることができますよ。
また動きません(3846日経過)
2009-03-10 09:28:32 / 遠藤先ほどの作業を続けておりました。

ダウンロードしたsend.cgiをそのままアップロードし、アクセスするとSPAM BLOCKと表示されます。
正常に動いていると思いましたので、
メールアドレスなどの設定を修正し、アップロードしました。

再び直接send.cgiにアクセスするとSPAM BLOCKと表示されます。
正常に動いていると思いましたので、
example.htmlからメールを送信したのですが、
Internal Server Errorとなります

再度直接send.cgiにアクセスするとSPAM BLOCKと表示されます。
正常に動いていると思うのですが・・・

どこかがおかしいのでしょうか?

英語サイト用のメールフォーム(3846日経過)
2009-03-10 08:58:49 / 遠藤ちなみにこのフォームを
日本語ページと英語ページ2つにぶら下げたいのですが、
可能なんでしょうか?

自動返信メールが必要かと思ったので、
send.cgi を複製、名前を変えて、
フォームを2つ作ろうかと思いますが、
できるのでしょうか?
Re:Re:Internal Server Errorとなります(3846日経過)
2009-03-10 08:54:09 / 遠藤ご返事ありがとうございます。

ダウンロードしたものをそのままアップすると、
SPAM が表示されましたので、動いているのだと思います。
Jcode.pmは入れています。

とりあえず動いているので、また少しづつ作業を進めてみます。
ありがとうございました。
(北海道に向かって一礼、いやいやいっぱい礼)
Re:Internal Server Errorとなります(3846日経過)
2009-03-09 23:28:40 / 和田Jcode.pmは入っていますか?check.cgiでJcode.pmがハイッテナイヨーみたいなエラーとか。
あとはsend.cgi内で設定ミスとか。ですかねぇ・・・。

一度、ダウンロードした状態のまま、アップしてsend.cgiに直接アクセスしてみてください。
DEBUGと表示されれば適切に動いていますし、それでもエラーの場合はJcodeが入っていない可能性があります。
Internal Server Errorとなります(3846日経過)
2009-03-09 21:20:22 / 遠藤メールフォームCGI UTF-8対応版を利用させていただこうと思い、
最初に間違えてメールフォームCGIを設置したら正常に動いたのですが、
UTF-8対応版に変えたところ、Internal Server Errorとなりました。

パーミッションのチェックは十分にやったつもりですが、
なんどやっても、データを差し替えても無理です。

最終いったんすべてのデータを削除し、もう一度最初っからやり直したのですが、
やはりInternal Server Errorとなりました。

check.cgiは正常に動くのですが、
何か問題があるのでしょうか?