シンクグラフィカ札幌

サポート掲示板跡地(2)

こちらの掲示板は終了しました。ご質問などはサポートセンターをご利用ください。

Re:mailformproの共有SSLのサーバーエラー(3707日経過)
2009-07-22 17:44:31 / 和田サーバ会社に問い合わせてみてください。
基本的に同一環境であれば動くはずですが、サーバによっては共有SSL環境下では実行環境が異なる場合があります。
mailformproの共有SSLのサーバーエラー(3707日経過)
2009-07-22 10:19:54 / ヒロシ無償提供とサポートに感謝します。

通常URLでは表示されるのに
ttp://suginami-ido.info/form/mail/example.html

共有SSLだとIEの場合HTTP500内部サーバーエラーになります。
ttps://server27.instantssl.co.jp/~su16111/form/mail/example.html

パーミッションはマニュアルの通りにしてあります。
過去ログを読んでもわかりませんでした。
サーバーはJoe'sウェブホスティングの共用レンタルサーバーです。
どうぞよろしくお願いします。

今年の抱負は
10キロやせるです。
Re:Re:Re:Re:Re:Re:Re:500エラーが出ます。(3709日経過)
2009-07-20 08:11:43 / 和田まず確認ですが携帯では動きませんけど大丈夫ですか?
Re:Re:Re:Re:Re:Re:500エラーが出ます。(3710日経過)
2009-07-19 22:37:26 / unknownすみません。

ttp://a-ni-ma.com/m_schedule.html


こちらになります。宜しくお願いします
Re:Re:Re:Re:Re:500エラーが出ます。(3710日経過)
2009-07-19 22:35:13 / 和田URLを
Re:Re:Re:Re:500エラーが出ます。(3710日経過)
2009-07-19 22:17:52 / クラウありがとうございます。
include.cgiはパーミッションなど直して作動し、確認画面まで行くようになりました。

しかし、メール送信をするとsend.cgiのページになってからブラウザ上が真っ白になってしまい、メールを送れません。
別ページでメールフォームを作っても同様です。
当然、メールを送ってもエラーになってしまいます。
これは、何が原因なのでしょうか。。
ちなみに、ソースを以下に記載しておきます。おかしな部分があればご指摘願います。


<br> 
<hr color="#A9A9A9" size=1>
チケット予約フォーム<br>
<form id="mailform" method="post" action="mailformpro2/mailformpro/send.cgi" onsubmit="return falsesubmit(this)">
<input type=hidden name="_subject" value="チケット予約">
<font size="1" color="#ffffff">ご氏名</font><br>
<input size="30" type="text" name="_ご氏名"><br>
<font size="1" color="#ffffff">E-mail</font><br>
<input size="30" type="text" name="_E-mail"><br>
<font size="1" color="#ffffff">予約枚数</font><br>
<select name="枚数" size="1">
<option selected>1</option>
<option>2</option>
<option>3</option>
<option>4</option>
<option>5</option>
 </select><BR>
<font size="1" color="#ffffff">備考</font><br>
<textarea name="備考" rows="5" cols="35" input size="30"></textarea>
<BR><BR><BR>

<input type="submit" value="送信する"> <input type="reset" value="リセット">
</FORM>

Re:Re:Re:500エラーが出ます。(3710日経過)
2009-07-19 05:28:58 / 和田include.cgiが動いていない!
Re:Re:500エラーが出ます。(3711日経過)
2009-07-18 22:52:15 / クラウこんばんは。
メールフォームを設置し、送信を試したら
「ERROR CODE5
Javascriptが有効ではありません。」
のエラー表示が出てしまいます。
ちなみにブラウザはIE及びSleipnirでjavascript設定は有効にしてあります。
設置手順はマニュアルの通りで、パーミッションの設定、Jcodeもフォルダに入れてある状態です。
サーバーはロリポップさんのサーバーで、ムームードメインによる独自ドメインです。

何が原因なのか全くわからず戸惑っております。
どうか救いの手を…お願いします。
Re:500エラーが出ます。(3729日経過)
2009-06-30 17:47:27 / 和田Perlのパスか文字コード・改行コードが怪しい!
500エラーが出ます。(3729日経過)
2009-06-30 17:44:06 / casiopeaお忙しいところ、大変恐縮でございますが、mailformpro2を使用してかっこいいフォームを作ろうと
ファーストサーバへUP、パーミッションの変更を行いましたが、check.cgiで、いきなり500エラー
cgi自体が動作していないような感じです・・・・

同じファイルを、Xサーバ上のテストサイトで動作確認したところ問題なく動作しているので、記述内容や設定では
ないと思われるのですが・・・・・汗

何か良いお知恵を拝借できればと思い書き込みました。
よろしくお願いいたします。
Re:有り難うございました!(3737日経過)
2009-06-22 19:32:15 / 和田うむ!とんでもないよ!設置おつかれさまっ!
有り難うございました!(3737日経過)
2009-06-22 19:30:53 / unknownな、なるほど。。
ご指定ありがとうございました!
おかげさまで無事 軌道しました!!
初心者の質問で大変お手数おかけいたしました。
Re:Re:Re:500エラー出ます。(3739日経過)
2009-06-20 10:42:00 / 和田URLはttpからフルパスで指定しないとダメですよ
Re:Re:500エラー出ます。(3740日経過)
2009-06-19 17:10:06 / 大田です。(2)素早いご返答、たいへんたいへんありがとうございます。
jcodeは、すでに「mailformpro」 のフォルダーの中に入れておりまする。
・・
・・
ダウンロードしたままの手を加えないcheck.cgiやsend.cgiを入れたり色々とやっているうちに、
メール自体は送られてくるようになりました!!

し、しかし、メールフォーム入力後の確認画面の後に表示される
thanksページの形がくずれて文字だけになってしまいます。

というか、この時、ブラウザに表示されるURLは
ttp://www.○○○.com/mailformpro2/mailformpro/send.cgi ですが、
これで正しいのでしょうか?

ちなみに config.cgi における設定は
  ▼ 
##サンクスページのURL
$config{"thanks_url"} = '/mailformpro2/thanks.html';
です。

試しに、ttp://www.○○○.com/mailformpro2/thanks.html とブラウザーに入力すると ちゃんと出ます。
(当たり前ですが・・)

きっと単なる、どこかのパス指定のミスではないかとは思うのですが、それがどこか判りません。。。
私は、いったいどこを間違っているのでしょうか??

申し訳ありませんが、もし判るようでしたら、ご指摘いただければ、感謝至極でございます。

ちなみに今年の抱負は
「お金持ちになる」もしくは「なりたい!」であります。
Re:500エラー出ます。(3740日経過)
2009-06-19 15:45:04 / 和田ロリポか・・・。私はロリポップが嫌いです!!だからサポートもしないっ!!なんてね・・・。
Jcodeは入っておりますか?
ttp://cgi.synck.com/Jcode.zip
↑このJcodeを解凍してJcode.pmとJcodeフォルダをsend.cgiと同じ階層にアップしてみてください。
500エラー出ます。(3740日経過)
2009-06-19 15:06:48 / 大田です。お忙しいところ、大変恐縮でございますが、mailformpro2の設営がうまく行きません。

Perl や cgi についはほんとど、というより全く判らない素人です。
とてもカッコ良いメールフォームなので、ぜひ使わせていただきたいと思い、
解凍してロリポップのサーバーにFFFTPでアップロードしました。

とりあえず、check.cgi にアクセスしてみると
【確認】ログファイルの書き出しは有効になっていません
という表示以外は出ないので大丈夫かと思い、

ホームページのトップ頁(index.html)から mailform(=example).htmlを開いて
→ 「メールフォーム」に必要事項を入力 → 確認画面で「上記内容を送信」をクリック したところ 
→ 500ERROR! になってしまいます。

きっと単純なミスだと想うのですが・・・。。。

う~んnnn、も、もしかしたら、(超)初心者の私の手には余るのでしょうかぁぁぁ!?
PROと名称がついているソフトに、(超)初心者の私が手を出した天罰なのでございましょうかぁ!?
神様、仏様、和田様 お助けをォォォ!! 

●meilformpro2を解凍し、サーバー(ロリポップ)のindex.htmlのある階層にフォルダーごとアップロード。

パーミッション設定

mailformpro 755

check.cgi 755
config.cgi 755
functions.cgi  755
include.cgi 755
postlog.cgi 755
send.cgi 755
serial.dat777
time.dat777
unique.dat777
※ちなみに uniqu.dat以外の .datは、再アップロードする際に自動的に600に書き換えられてしまいます。

●mailformpro2/mailformpro/check.cgiの
 1行目   #!/usr/bin/perl

●同じく config.cgi の中の
##sendmailのパス
$config{"sendmail"} = '/usr/lib/sendmail';

●同じく send.cgi の
1行目    #!/usr/bin/perl

●同じ include.cgi の
1行目    #!/usr/bin/perl

ちなみに
「.cgi」 の書き換えは、TeraPad を使用しています。

お忙しいとは思いますが、よろしくご教示のほどお願いいたします。
Re:Re:Re:sendmailのパスの設定 500エラーについて(3819日経過)
2009-04-01 15:16:18 / 和田無視していっす!設置おつかれさんですた~!
Re:Re:sendmailのパスの設定 500エラーについて(3819日経過)
2009-04-01 15:01:31 / ume和田様。

返信ありがとうございます
ダウンロードしたままのものをアップしてみたらちゃんと動いたので、
もう一度1からやり直してみたら、動作しました!(何度かやったはずなのになぜか…)

未だにcheck.cgiで怒られてるんですが… 動くってことは無視して大丈夫ですよね??

ありがとうございます。お手数をおかけしましたっっ
Re:sendmailのパスの設定 500エラーについて(3819日経過)
2009-04-01 13:53:20 / 和田500エラーはsendmailのパスと関係ないです~。
一度、ダウンロードしたままの状態のsend.cgiをアップして頂いて、直接アクセスしてみてください。
SPAM BLOCKと表示されたらプログラム自体が無事動作してるということです。
sendmailのパスの設定 500エラーについて(3819日経過)
2009-04-01 11:19:38 / ume初心者すぎてきっと自分があんぽんたんな事をやってるだけなのかもしれませんが、
どうしてもmailformUTF-8が動作してくれないので教えてください。


500エラーが出てしまうので、check.cgiでチェックしてみると
「このサーバのsendmailのパスはたぶんだけどこうっ!!」と怒られてしまい…
(サクラなので表示のパスの通りで usr/sbin/sendmail )
パスを確認して再度、動作確認をしてみてもやはり500エラーから変わらず。
check.cgiも同じ内容のまま…

cgi内の「テスト時の誤送信を制御」もちゃんと0に直してあることも確認済みです。
…初心者すぎてこれ以上、解決策が思い浮かびませんでした。すみませんっ

プログラム内必要事項の変更、perlのパス変更、パーミッションの設定…と
進めていったんですが、ここでどうしてもつまづいてしまいました。

初歩的な部分でのミスのせいかもしれないんですが(多分きっとそう)
よろしくおねがいします。。。