シンクグラフィカ札幌

サポート掲示板跡地(2)

こちらの掲示板は終了しました。ご質問などはサポートセンターをご利用ください。

Re:Re:Re:Re:Re:メールフォーム 文字化けしたのでUTF-8版にしたところ…(3803日経過)
2009-04-22 00:29:23 / 和田すいません・・・そこまで考えが及びませんでしたよ・・・。
お手数をおかけしました!おつかれさんですた~!
Re:Re:Re:Re:メールフォーム 文字化けしたのでUTF-8版にしたところ…(3804日経過)
2009-04-21 11:05:25 / AT_KANEKO和田さん、解決しましたぁぁぁぁ〜〜〜〜〜!

あれから、いぢっていないファイルを、
Macのエディタで改行コードをUNIX(LF)に変換して、
FTPのバイナリーモードで上げでみたり、
(こうするとよいと、Mac向けのアドヴァイスを見かけました。)
それでもだめだったので、
XP(ぢつは持ってるんですが使いこなせてないもので)で
Macのデータを上げてみたけどやっぱりだめだったので、
DLし直して、素のままFFFTPで上げてみたけれど、ほんとにダメで、
こりゃぁ万策尽きたと思い、
今朝サーバーのサポートに電話してみたところ、
サポート外なのですが、といいながら調べてくれて、なんと、

「mailform」フォルダのパーミッションを、777ではなく755にしたら、
動きましァァァァァーーーーーーーーーーーーーーーーーーーー!

さくらレンタルサーバー、激安なので一抹の不安があったのですが、
一気に気に入りました。
いまどき電話サポートしてくれるっていうのも涙ものです。

これでここ数日の睡眠不足が解消しそうです。
和田さんにもお手数おかけ致しました。

もう、HTMLファイルを全部Shift_jisにするしなかないか!?
とまで思っていたので、よかったです-(涙)。

でも、なかのファイルに777(count.dat)のものがあるのに、
それの入ったフォルダは755にするんですね。
私の理解能力をやはり超えています。

お騒がせ致しました!m(_ _)m
Re:Re:Re:メールフォーム 文字化けしたのでUTF-8版にしたところ…(3805日経過)
2009-04-20 15:41:43 / 和田postcodesはアップしなくても動きますよっ!いや~当方、Macでアップ作業したこと無いのであんましわからないんですよねMacでのアップって・・・。てへっ。boot campとかでWindowsとか入ってたらWindowsで試して頂けたらなって・・・。あちきもMacでちょっと試してみますねっ!すんません・・・。
Re:Re:メールフォーム 文字化けしたのでUTF-8版にしたところ…(3805日経過)
2009-04-20 11:07:54 / unknown早速の回答ありがとうございます!

ですが、いぢらないデータ、フォルダごと上げてみましたが、
変わらず500errorでした。

Macで転送は、問題が多いと聞いたこともありますが、
今回はテキストエディタは使っておりません。
FTPソフトの自動転送設定では、
.cgiはASCIIに割り振っています。

また、当方山間部でADSLのため、
一回上げるのに1時間かかります。
このあとのテストで、
「postcodes」以外のファイルだけ上げるっていうのは、
NGなのでしょうか???

どうかお助け下さい〜。



Re:メールフォーム 文字化けしたのでUTF-8版にしたところ…(3805日経過)
2009-04-20 07:55:36 / 和田いったん、ダウンロードしたそのままの状態でアップしてみてもらってもよいですかね。さくらならたぶんそのままアップしても動くと思うので。HTML側は変更はいらないと思います。UTF-8版はUTF-8という都合でBOMアリナシで動いたり動かなかったりするのがアレなんですよね・・・。ひとまずまったくいぢらないでアップしてcheck.cgiが動くかどうかお試しを!
メールフォーム 文字化けしたのでUTF-8版にしたところ…(3805日経過)
2009-04-20 00:00:39 / AT_KANEKOとてもすてきなメールフォームをありがとうございます。
CGIはいつも文字コードでつまずいてしまいます。

今回、よく調べずにSTD6.1をダウンロード、
加工してアップしたところ、あっさり動いてほっとしたのですが、
送られてきたメールが文字化けしてしまいました。

よく自分のファイルを確認すると、UTF-8だったので、
STD6.1 UTF-8版を再度DLして設置したのですが、
今度はcheck.cgiへのテストで500errorが出てしまいました。

パールのパスは、穴があく程見直しても、
/usr/bin/perl
です…
最初はここもいじらずに動いてくれました。

環境は、
Mac OS X
DreamweaverCS3
Jedit X
Transmit(自動判別でアップしています)

サーバーは「さくらレンタルサーバー」です。
ttp://hyakusyo-kaneko.sakura.ne.jp/order.html
ttp://hyakusyo-kaneko.sakura.ne.jp/mailform/check.cgi

HTMLは動いた時のままのファイルなのですが、(STD6.1よりコピペ)
それだとダメでしょうか??

あと、通信欄を必須ではなくしたいのですが、
どうすればよいでしょうか???

いっこうに初心者から抜け出ません。
何卒よろしくお願い致します。