シンクグラフィカ札幌

サポート掲示板跡地(2)

こちらの掲示板は終了しました。ご質問などはサポートセンターをご利用ください。

Re:Re:Re:Re:Re:Re:Re:「メールフォームCGI」がどうしてもサーバーエラーになる(3728日経過)
2009-07-03 02:53:31 / 和田うぃーむしゅー!
Re:Re:Re:Re:Re:Re:「メールフォームCGI」がどうしてもサーバーエラーになる(3732日経過)
2009-06-29 16:51:28 / 橋本何とか解決しましたのでご報告します。

原因は、jcode.plをCGIディレクトリーにCRコードを変換せずに入れていたためでした。
拡張子がCGIでないため静的ファイルと思い、htmlと同じようにアップロードしました。
先々週は、CGIディレクトリーにアップロードするファイル群をまとめてCRコードに変換してから
アップロードしたため、結果的に動作したようです。
お騒がせしました。
そして、アドバイスありがとうございました。

Re:Re:Re:Re:Re:「メールフォームCGI」がどうしてもサーバーエラーになる(3737日経過)
2009-06-24 21:14:26 / 和田んー。なんでしょうね。URLをお知らせいただいてもよいですか?
あとどこのサーバ使ってるかも教えてください。
Re:Re:Re:Re:「メールフォームCGI」がどうしてもサーバーエラーになる(3737日経過)
2009-06-24 12:28:35 / 橋本素早いご回答、ありがとうございます。
実は、メモ帳は使っていないのです。
というか、全くCGIを編集せずにアップロードしてもだめなのです。
(先週は動作しました)
example.htmlの「send.cgi」部分を「check.cgi」に書き換えると動作はしますが
文字化けがひどく内容は不明です(画面コピーを添付します)。

アップロードはFFFTPを使っていますが、CGIアスキーモードアップロード時は、
CRを取り去るどころか、逆に付加してしまうのです。
このため、事前にLFに変換してからバイナリーモードでアップロードしています。
変換はLFENCやTerapadで行なっています。
このCGIをアスキーモードでアップロードすると、ご丁寧にCR+LFに戻ってしまいます。

あと、get.cgiは正常に動作しているようなので、全く同じ方法でアップロードしている
send.cgiが動かないあたりに原因が隠れていないでしょうか。

よろしくお願い致します。
check.png
Re:Re:Re:「メールフォームCGI」がどうしてもサーバーエラーになる(3737日経過)
2009-06-24 10:09:52 / 和田メモ帳をとりあえずやめるところからはじめましょうか。
また一般的なサーバではCGIファイルはバイナリではなくテキストですね。
Re:Re:「メールフォームCGI」がどうしてもサーバーエラーになる(3737日経過)
2009-06-24 10:03:35 / unknownご連絡ありがとうございます。
CGI編集はメモ帳とTeraPadを使っています(主にメモ帳)。
アップロードはLFEUCでUNIX形式に変換してから、FFFTPでバイナリー転送しています。

get.cgiは正常に動作するので、いろいろな転送方法による動作を確認してみました。
その結果、
・LFENCでUNIX形式に変換後FFFTPでバイナリー転送
・TerapadでShift_JIS or EUC or UTF-8N (改行LF) で保存してFFFTPでバイナリー転送
が動作することがわかりました(FFFTPアスキー転送は全滅)。
しかし、send.cgiはどの方法でアップロードしてもだめです。

send.cgiのperlパスとsendmailパスは変更することなく動作した実績があるので、全く編集しない
状態でも「DEBUG」が表示されるはずなのですが。

よろしくお願い致します。


Re:「メールフォームCGI」がどうしてもサーバーエラーになる(3738日経過)
2009-06-23 22:32:34 / 和田CGIの編集はどんなソフトで行っておりますか。またサーバはどこのサーバですか。
「メールフォームCGI」がどうしてもサーバーエラーになる(3738日経過)
2009-06-23 19:50:02 / 橋本和田様、お助け下さい。
先週までは正常に動作していましたが、本日ファイルをさわったらサーバーエラーが出るようになり、
何をしても直りません。
サーバーはCGIは専用ディレクトリーに、mailform.jsはCGI専用ディレクトリー以外に置かなければならない
タイプです。
example.htmlのsend.cgi部分をcheck.cgiにして動かすと、ひどく文字化けして「sendmailのパスが違う」
らしき表示が出ます(実際にはsendmailのパスはサーバー推奨設定になっています)。
send.cgiのアップロードは、lfencでUNIX形式に変換してからFFFTPバイナリーモードで行なっており、
先週はこの方法で動作しました。

念のためにフォームのCGIパスを故意に間違えた場所にして試したところ、404エラーとなりました。
このため、send.cgiにアクセスするとサーバーエラーが発生することがわかりました。

何とかお助け下さい....

よろしくお願い致します。